
<!-- language redirection -->



<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>MAXIMUM ROCKNROLL  &raquo; New Blood! DIASPORA, CAUSA, LAISKAT SILMÄT, OKI MOKI, and returning guest, SEX SCENES</title>
<meta name="description" content="International DIY punk fanzine, radio show, website and record label since 1977." />
<meta name="generator" content="WordPress 4.8" /> <!-- leave this for stats -->
<meta name="google-site-verification" content="GyOqi_-vzlyxS_yW_v7xUK7illH-phNnZKmEQeWEWB4" />
<link rel="stylesheet" href="http://www.maximumrocknroll.com/wp-content/themes/freshy/style.css" type="text/css" media="screen" title="Freshy"/>
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://www.maximumrocknroll.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="http://www.maximumrocknroll.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="http://www.maximumrocknroll.com/feed/atom/" />
<link rel="pingback" href="http://www.maximumrocknroll.com/xmlrpc.php" />
	<link rel='archives' title='June 2017' href='http://www.maximumrocknroll.com/2017/06/' />
	<link rel='archives' title='May 2017' href='http://www.maximumrocknroll.com/2017/05/' />
	<link rel='archives' title='April 2017' href='http://www.maximumrocknroll.com/2017/04/' />
	<link rel='archives' title='March 2017' href='http://www.maximumrocknroll.com/2017/03/' />
	<link rel='archives' title='February 2017' href='http://www.maximumrocknroll.com/2017/02/' />
	<link rel='archives' title='January 2017' href='http://www.maximumrocknroll.com/2017/01/' />
	<link rel='archives' title='December 2016' href='http://www.maximumrocknroll.com/2016/12/' />
	<link rel='archives' title='November 2016' href='http://www.maximumrocknroll.com/2016/11/' />
	<link rel='archives' title='October 2016' href='http://www.maximumrocknroll.com/2016/10/' />
	<link rel='archives' title='September 2016' href='http://www.maximumrocknroll.com/2016/09/' />
	<link rel='archives' title='August 2016' href='http://www.maximumrocknroll.com/2016/08/' />
	<link rel='archives' title='July 2016' href='http://www.maximumrocknroll.com/2016/07/' />
	<link rel='archives' title='June 2016' href='http://www.maximumrocknroll.com/2016/06/' />
	<link rel='archives' title='May 2016' href='http://www.maximumrocknroll.com/2016/05/' />
	<link rel='archives' title='April 2016' href='http://www.maximumrocknroll.com/2016/04/' />
	<link rel='archives' title='March 2016' href='http://www.maximumrocknroll.com/2016/03/' />
	<link rel='archives' title='February 2016' href='http://www.maximumrocknroll.com/2016/02/' />
	<link rel='archives' title='January 2016' href='http://www.maximumrocknroll.com/2016/01/' />
	<link rel='archives' title='December 2015' href='http://www.maximumrocknroll.com/2015/12/' />
	<link rel='archives' title='November 2015' href='http://www.maximumrocknroll.com/2015/11/' />
	<link rel='archives' title='October 2015' href='http://www.maximumrocknroll.com/2015/10/' />
	<link rel='archives' title='September 2015' href='http://www.maximumrocknroll.com/2015/09/' />
	<link rel='archives' title='August 2015' href='http://www.maximumrocknroll.com/2015/08/' />
	<link rel='archives' title='July 2015' href='http://www.maximumrocknroll.com/2015/07/' />
	<link rel='archives' title='June 2015' href='http://www.maximumrocknroll.com/2015/06/' />
	<link rel='archives' title='May 2015' href='http://www.maximumrocknroll.com/2015/05/' />
	<link rel='archives' title='April 2015' href='http://www.maximumrocknroll.com/2015/04/' />
	<link rel='archives' title='March 2015' href='http://www.maximumrocknroll.com/2015/03/' />
	<link rel='archives' title='February 2015' href='http://www.maximumrocknroll.com/2015/02/' />
	<link rel='archives' title='January 2015' href='http://www.maximumrocknroll.com/2015/01/' />
	<link rel='archives' title='December 2014' href='http://www.maximumrocknroll.com/2014/12/' />
	<link rel='archives' title='November 2014' href='http://www.maximumrocknroll.com/2014/11/' />
	<link rel='archives' title='October 2014' href='http://www.maximumrocknroll.com/2014/10/' />
	<link rel='archives' title='September 2014' href='http://www.maximumrocknroll.com/2014/09/' />
	<link rel='archives' title='August 2014' href='http://www.maximumrocknroll.com/2014/08/' />
	<link rel='archives' title='July 2014' href='http://www.maximumrocknroll.com/2014/07/' />
	<link rel='archives' title='June 2014' href='http://www.maximumrocknroll.com/2014/06/' />
	<link rel='archives' title='May 2014' href='http://www.maximumrocknroll.com/2014/05/' />
	<link rel='archives' title='April 2014' href='http://www.maximumrocknroll.com/2014/04/' />
	<link rel='archives' title='March 2014' href='http://www.maximumrocknroll.com/2014/03/' />
	<link rel='archives' title='February 2014' href='http://www.maximumrocknroll.com/2014/02/' />
	<link rel='archives' title='January 2014' href='http://www.maximumrocknroll.com/2014/01/' />
	<link rel='archives' title='December 2013' href='http://www.maximumrocknroll.com/2013/12/' />
	<link rel='archives' title='November 2013' href='http://www.maximumrocknroll.com/2013/11/' />
	<link rel='archives' title='October 2013' href='http://www.maximumrocknroll.com/2013/10/' />
	<link rel='archives' title='September 2013' href='http://www.maximumrocknroll.com/2013/09/' />
	<link rel='archives' title='August 2013' href='http://www.maximumrocknroll.com/2013/08/' />
	<link rel='archives' title='July 2013' href='http://www.maximumrocknroll.com/2013/07/' />
	<link rel='archives' title='June 2013' href='http://www.maximumrocknroll.com/2013/06/' />
	<link rel='archives' title='May 2013' href='http://www.maximumrocknroll.com/2013/05/' />
	<link rel='archives' title='April 2013' href='http://www.maximumrocknroll.com/2013/04/' />
	<link rel='archives' title='March 2013' href='http://www.maximumrocknroll.com/2013/03/' />
	<link rel='archives' title='February 2013' href='http://www.maximumrocknroll.com/2013/02/' />
	<link rel='archives' title='January 2013' href='http://www.maximumrocknroll.com/2013/01/' />
	<link rel='archives' title='December 2012' href='http://www.maximumrocknroll.com/2012/12/' />
	<link rel='archives' title='November 2012' href='http://www.maximumrocknroll.com/2012/11/' />
	<link rel='archives' title='October 2012' href='http://www.maximumrocknroll.com/2012/10/' />
	<link rel='archives' title='September 2012' href='http://www.maximumrocknroll.com/2012/09/' />
	<link rel='archives' title='August 2012' href='http://www.maximumrocknroll.com/2012/08/' />
	<link rel='archives' title='July 2012' href='http://www.maximumrocknroll.com/2012/07/' />
	<link rel='archives' title='June 2012' href='http://www.maximumrocknroll.com/2012/06/' />
	<link rel='archives' title='May 2012' href='http://www.maximumrocknroll.com/2012/05/' />
	<link rel='archives' title='April 2012' href='http://www.maximumrocknroll.com/2012/04/' />
	<link rel='archives' title='March 2012' href='http://www.maximumrocknroll.com/2012/03/' />
	<link rel='archives' title='February 2012' href='http://www.maximumrocknroll.com/2012/02/' />
	<link rel='archives' title='January 2012' href='http://www.maximumrocknroll.com/2012/01/' />
	<link rel='archives' title='December 2011' href='http://www.maximumrocknroll.com/2011/12/' />
	<link rel='archives' title='November 2011' href='http://www.maximumrocknroll.com/2011/11/' />
	<link rel='archives' title='October 2011' href='http://www.maximumrocknroll.com/2011/10/' />
	<link rel='archives' title='September 2011' href='http://www.maximumrocknroll.com/2011/09/' />
	<link rel='archives' title='August 2011' href='http://www.maximumrocknroll.com/2011/08/' />
	<link rel='archives' title='July 2011' href='http://www.maximumrocknroll.com/2011/07/' />
	<link rel='archives' title='June 2011' href='http://www.maximumrocknroll.com/2011/06/' />
	<link rel='archives' title='May 2011' href='http://www.maximumrocknroll.com/2011/05/' />
	<link rel='archives' title='April 2011' href='http://www.maximumrocknroll.com/2011/04/' />
	<link rel='archives' title='March 2011' href='http://www.maximumrocknroll.com/2011/03/' />
	<link rel='archives' title='February 2011' href='http://www.maximumrocknroll.com/2011/02/' />
	<link rel='archives' title='January 2011' href='http://www.maximumrocknroll.com/2011/01/' />
	<link rel='archives' title='December 2010' href='http://www.maximumrocknroll.com/2010/12/' />
	<link rel='archives' title='November 2010' href='http://www.maximumrocknroll.com/2010/11/' />
	<link rel='archives' title='October 2010' href='http://www.maximumrocknroll.com/2010/10/' />
	<link rel='archives' title='September 2010' href='http://www.maximumrocknroll.com/2010/09/' />
	<link rel='archives' title='August 2010' href='http://www.maximumrocknroll.com/2010/08/' />
	<link rel='archives' title='July 2010' href='http://www.maximumrocknroll.com/2010/07/' />
	<link rel='archives' title='June 2010' href='http://www.maximumrocknroll.com/2010/06/' />
	<link rel='archives' title='May 2010' href='http://www.maximumrocknroll.com/2010/05/' />
	<link rel='archives' title='April 2010' href='http://www.maximumrocknroll.com/2010/04/' />
	<link rel='archives' title='March 2010' href='http://www.maximumrocknroll.com/2010/03/' />
	<link rel='archives' title='February 2010' href='http://www.maximumrocknroll.com/2010/02/' />
	<link rel='archives' title='January 2010' href='http://www.maximumrocknroll.com/2010/01/' />
	<link rel='archives' title='December 2009' href='http://www.maximumrocknroll.com/2009/12/' />
	<link rel='archives' title='November 2009' href='http://www.maximumrocknroll.com/2009/11/' />
	<link rel='archives' title='October 2009' href='http://www.maximumrocknroll.com/2009/10/' />
	<link rel='archives' title='September 2009' href='http://www.maximumrocknroll.com/2009/09/' />
	<link rel='archives' title='August 2009' href='http://www.maximumrocknroll.com/2009/08/' />
	<link rel='archives' title='July 2009' href='http://www.maximumrocknroll.com/2009/07/' />
	<link rel='archives' title='June 2009' href='http://www.maximumrocknroll.com/2009/06/' />
	<link rel='archives' title='May 2009' href='http://www.maximumrocknroll.com/2009/05/' />
	<link rel='archives' title='April 2009' href='http://www.maximumrocknroll.com/2009/04/' />
	<link rel='archives' title='March 2009' href='http://www.maximumrocknroll.com/2009/03/' />
	<link rel='archives' title='February 2009' href='http://www.maximumrocknroll.com/2009/02/' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="MAXIMUM ROCKNROLL &raquo; New Blood! DIASPORA, CAUSA, LAISKAT SILMÄT, OKI MOKI, and returning guest, SEX SCENES Comments Feed" href="http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.maximumrocknroll.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='social-logos-css'  href='http://www.maximumrocknroll.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.maximumrocknroll.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.9' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.1.11 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	var disableStr = 'ga-disable-UA-22798238-1';
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-22798238-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='http://www.maximumrocknroll.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.maximumrocknroll.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.maximumrocknroll.com/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"http:\/\/www.maximumrocknroll.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.maximumrocknroll.com/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/www.maximumrocknroll.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.maximumrocknroll.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<link rel='https://api.w.org/' href='http://www.maximumrocknroll.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.maximumrocknroll.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.maximumrocknroll.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='MRR Radio #1561 • 6/11/17' href='http://www.maximumrocknroll.com/mrr-radio-1561/' />
<meta name="generator" content="WordPress 4.8" />
<link rel="canonical" href="http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/" />
<link rel='shortlink' href='http://wp.me/pvkt9-7Vf' />
<link rel="alternate" type="application/json+oembed" href="http://www.maximumrocknroll.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.maximumrocknroll.com%2Fnew-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.maximumrocknroll.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.maximumrocknroll.com%2Fnew-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes%2F&#038;format=xml" />

<!-- This site is using AdRotate v4.3 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:1px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
<link type="text/css" rel="stylesheet" href="http://www.maximumrocknroll.com/wp-content/plugins/simple-pull-quote/css/simple-pull-quote.css" />

<link rel='dns-prefetch' href='//v0.wordpress.com'>

	<style type="text/css">
	.description {
		color:#ADCF20;
	}
	#content .commentlist dd.author_comment {
		background-color:#a3cb00 !important;
	}
	html > body #content .commentlist dd.author_comment {
		background-color:#a3cb00 !important;
	}
	#content .commentlist dt.author_comment .date {
		color:#a3cb00 !important;
		border-color:#a3cb00 !important;
	}
	#content .commentlist .author_comment .author,
	#content .commentlist .author_comment .author a {
		color:#a3cb00 !important;
		border-color:#a3cb00 !important;
	}
	#sidebar {
		background-color:#FFFFFF;
	}
	*::-moz-selection {
		background-color:#FF3C00;
	}



	#sidebar a:hover,
	#sidebar .current_page_item li a:hover,
	#sidebar .current-cat li a:hover,
	#sidebar .current_page_item a,
	#sidebar .current-cat a ,
	.readmore,
	#content .postmetadata a
	{
		color : #FF3C00;
	}
	
	#title_image {
		margin:0;
		text-align:left;
		display:block;
		height:95px;
				background-image:url("http://www.maximumrocknroll.com/wp-content/themes/freshy/images/headers/MRR_classic_logo_w_face.gif");
	
			}
	
	</style>

			<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<style type="text/css" media="screen"></style>
<!-- WordPress Facebook Open Graph protocol plugin (WPFBOGP v2.0.13) http://rynoweb.com/wordpress-plugins/ -->
<meta property="fb:admins" content="190726258204, 100000392752603"/>
<meta property="og:url" content="http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/"/>
<meta property="og:title" content="&lt;em&gt;New Blood!&lt;/em&gt; DIASPORA, CAUSA, LAISKAT SILMÄT, OKI MOKI, and returning guest, SEX SCENES"/>
<meta property="og:site_name" content="MAXIMUM ROCKNROLL"/>
<meta property="og:description" content=""/>
<meta property="og:type" content="article"/>
<meta property="og:image" content="http://www.maximumrocknroll.com/wp-content/uploads/2012/02/MRR-twitter-icon.jpg"/>
<meta property="og:image" content="http://maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg"/>
<meta property="og:image" content="http://www.maximumrocknroll.com/wp-content/uploads/2016/12/sex-scenes-band-photo-465x310.jpg"/>
<meta property="og:image" content="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/sexScenesAlbumArtwork2-300x300.jpg"/>
<meta property="og:image" content="http://maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg"/>
<meta property="og:image" content="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandPhoto-465x388.jpg"/>
<meta property="og:image" content="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandLogo-465x428.jpg"/>
<meta property="og:image" content="http://maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg"/>
<meta property="og:image" content="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandPhoto-465x372.jpg"/>
<meta property="og:image" content="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandLogo-300x300.jpg"/>
<meta property="og:image" content="http://maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg"/>
<meta property="og:image" content="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaGroupPhoto-465x310.jpg"/>
<meta property="og:image" content="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaBandLogo-465x86.jpg"/>
<meta property="og:image" content="http://maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg"/>
<meta property="og:image" content="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/diasporaBandLogo-465x341.jpg"/>
<meta property="og:image" content="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaGroupPhoto-465x310.jpg"/>
<meta property="og:locale" content="en_us"/>
<!-- // end wpfbogp -->
			<style type="text/css" id="wp-custom-css">
				/*
Welcome to Custom CSS!

CSS (Cascading Style Sheets) is a kind of code that tells the browser how
to render a web page. You may delete these comments and get started with
your customizations.

By default, your stylesheet will be loaded after the theme stylesheets,
which means that your rules can take precedence and override the theme CSS
rules. Just write here what you want to change, you don't need to copy all
your theme's stylesheet content.
*/
.entry {
	margin: 0;
	text-align: left;
	line-height: 17px;
	font-size: 12px;
}

.smaller {
	font-size: .9em;
	line-height: 1.3em;
}

.menu li ul {
	width: 12em;
}

.menu li:hover ul {
	z-index: 100;
}

.mrr_date_author {
	margin: 0;
	color: #aaa;
	font-weight: bold;
}

#sidebar a {
	color: #ff3c00;
}

.description {
	color: darkGray;
	background: black;
	height: 20px;
	margin: 0 10px;
}

/* space around "Buy this issue" and "Download this issue" buttons */
#sidebar .wp-image-21204, .wp-image-21202, .wp-image-21207 {
	margin-top: 5px;
}

/* this didn't work so added code directly to style.css
#title_image {
	background: url("images/headers/MRR_logo_white_on_black_780x105.gif") repeat-y scroll center center transparent !important;
	height: 105px;
}
*/
/* for horiz lines between records on discography pg (added  to cells it applies to) */
td.mrrdiscog {
	border-bottom: 1px solid #000;
	padding: 5px 0 10px;
}

td {
	padding: 10px 0;
	text-align: justify;
}			</style>
		
<script type='text/javascript' src='http://www.maximumrocknroll.com/wp-content/plugins/wp-spamshield/js/jscripts.php'></script> 
</head>
<body>

<div id="page">
	
	<!-- header -->
	<div id="header">
		<!-- Paul changed <div id="title"> to <div id="mrr_title"> and, in style.css line 86, changed  "#title" to "#mrr_title" to fix conflict with Front End Uploader plugin using "title" id in the forms ...BUT NEVER MIND, that fucked up appearance of header...Instead, flipped position of title_image and title (which ic basically just the descrption). Still a sloppy solution to plugin conflict :( -->
		<div id="title_image"></div>
		<div id="title">
			<div class="description">
				<small>International DIY punk fanzine, radio show, website and record label since 1977.</small>
			</div>
		</div>

	</div>
	
	<!-- main div -->
	<div id="frame">

	<!-- main menu -->
 <div class="menu-og-menu-container"><ul id="menu-og-menu" class="menu"><li id="menu-item-7194" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-7194"><a href="http://www.maximumrocknroll.com/">Home</a></li>
<li id="menu-item-26669" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-26669"><a href="http://www.maximumrocknroll.com/features/">Web Features</a>
<ul  class="sub-menu">
	<li id="menu-item-26670" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26670"><a href="http://www.maximumrocknroll.com/cat/new-issue/">Latest Issue of MRR</a></li>
	<li id="menu-item-26671" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26671"><a href="http://www.maximumrocknroll.com/cat/shows/mrr-presents/">MRR Presents Shows</a></li>
	<li id="menu-item-26674" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26674"><a href="http://www.maximumrocknroll.com/cat/new-bands/">New Blood</a></li>
	<li id="menu-item-26672" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26672"><a href="http://www.maximumrocknroll.com/cat/create-to-destroy/">Create to Destroy!</a></li>
	<li id="menu-item-26673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26673"><a href="http://www.maximumrocknroll.com/cat/record-of-the-week/">Record of the Week</a></li>
	<li id="menu-item-26675" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26675"><a href="http://www.maximumrocknroll.com/funnies/">Friday Funnies</a></li>
</ul>
</li>
<li id="menu-item-17269" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17269"><a href="http://www.maximumrocknroll.com/cat/new-issue/">Magazine</a>
<ul  class="sub-menu">
	<li id="menu-item-21161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21161"><a href="http://www.maximumrocknroll.com/cat/mrr-magazine/new-issue/">New Issue</a></li>
	<li id="menu-item-15971" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15971"><a href="http://www.maximumrocknroll.com/mrr-bibliography/">MRR Bibliography and Back Issues</a></li>
	<li id="menu-item-27604" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27604"><a href="http://www.maximumrocknroll.com/mrr-archive-project/">The MRR Archive Project</a></li>
</ul>
</li>
<li id="menu-item-8705" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8705"><a href="http://store.maximumrocknroll.com#new_tab" onclick="__gaTracker('send', 'event', 'outbound-menu', 'http://store.maximumrocknroll.com#new_tab', 'Webstore');" target="_blank">Webstore</a></li>
<li id="menu-item-7198" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-7198"><a href="http://www.maximumrocknroll.com/distro/">Distro</a>
<ul  class="sub-menu">
	<li id="menu-item-11498" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11498"><a href="http://www.maximumrocknroll.com/distro/">MRR Distribution</a></li>
	<li id="menu-item-7453" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7453"><a href="http://www.maximumrocknroll.com/distro/intl-distro/">Int&#8217;l distros</a></li>
	<li id="menu-item-7452" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7452"><a href="http://www.maximumrocknroll.com/distro/diy/">Distro It Yourself</a></li>
</ul>
</li>
<li id="menu-item-7200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-7200"><a href="http://www.maximumrocknroll.com/cat/mrr-radio">MRR Radio</a></li>
<li id="menu-item-22463" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-22463"><a href="http://www.maximumrocknroll.com/ads/">Ads</a>
<ul  class="sub-menu">
	<li id="menu-item-7455" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7455"><a href="http://www.maximumrocknroll.com/ads/">Advertise in MRR</a></li>
	<li id="menu-item-7454" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7454"><a href="http://www.maximumrocknroll.com/ads/banner-ads/">Banner Ads</a></li>
</ul>
</li>
<li id="menu-item-7203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-7203"><a href="http://www.maximumrocknroll.com/about/">Info</a>
<ul  class="sub-menu">
	<li id="menu-item-27603" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27603"><a href="http://www.maximumrocknroll.com/mrr-archive-project/">MRR Archive</a></li>
	<li id="menu-item-16346" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16346"><a href="http://www.maximumrocknroll.com/contact/">Contact</a></li>
	<li id="menu-item-16345" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16345"><a href="http://www.maximumrocknroll.com/submit/">Submissions</a></li>
	<li id="menu-item-11500" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11500"><a href="http://www.maximumrocknroll.com/about/">About MRR</a></li>
	<li id="menu-item-9017" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9017"><a href="http://www.maximumrocknroll.com/2011/03/14/the-mrr-records-discography-a-history/">MRR Records Discography</a></li>
	<li id="menu-item-7451" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7451"><a href="http://www.maximumrocknroll.com/about/tim-yo/">Tim Yo</a></li>
</ul>
</li>
<li id="menu-item-7204" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7204"><a href="http://www.maximumrocknroll.com/cat/top-tens">Top Tens</a></li>
<li id="menu-item-7202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7202"><a href="http://www.maximumrocknroll.com/donate/">Donate</a></li>
<li id="menu-item-7201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7201"><a href="http://www.maximumrocknroll.com/contact/">Contact</a></li>
<li id="menu-item-21487" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21487"><a href="http://www.maximumrocknroll.com/cat/get-involved/">Get Involved!</a></li>
</ul></div>	
	<hr style="display:none"/>
	<div id="content">
<p style="padding:0 15px">

<div class="g g-1"><div class="g-single a-33"><a class="gofollow" data-track="MzMsMSwxLDYw" href="http://1859records.bandcamp.com/" target="_blank"><img src="http://www.maximumrocknroll.com/wp-content/banners/1859Records_banner_PaulAnimated.gif"></a></div></div></p>

			
						
			<div class="post" id="post-30457">
				
				<h2><a href="http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/" rel="bookmark" title="Read <em>New Blood!</em> DIASPORA, CAUSA, LAISKAT SILMÄT, OKI MOKI, and returning guest, SEX SCENES"><em>New Blood!</em> DIASPORA, CAUSA, LAISKAT SILMÄT, OKI MOKI, and returning guest, SEX SCENES</a></h2>
				
<!-- ( !in_category('258') && !in_category('275') ) and php tags added by Paul to remove date and author from single posts in "new-issue", "current-issue" and "webstore" categories -->				

	<br/><small class="mrr_date_author">June 15th, 2017 by <a href="http://www.maximumrocknroll.com/author/newblood/" title="Posts by Pirouz" rel="author">Pirouz</a> </small>
					
				<div class="entry">
					<p><em>“New Blood” is our <a href="http://maximumrocknroll.com/cat/new-bands/"><strong>weekly feature</strong></a> spotlighting new bands from around the world! See below for info on how to submit. Now, check out some killer new shit…</em></p>
<p><strong>Band name:</strong><br />
<a href="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/diasporaBandLogo.jpg"><img data-attachment-id="30466" data-permalink="http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/diasporabandlogo/" data-orig-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/diasporaBandLogo.jpg" data-orig-size="600,440" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="diasporaBandLogo" data-image-description="" data-medium-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/diasporaBandLogo-300x220.jpg" data-large-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/diasporaBandLogo-465x341.jpg" src="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/diasporaBandLogo-465x341.jpg" alt="" width="465" height="341" class="alignnone size-large wp-image-30466" srcset="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/diasporaBandLogo-465x341.jpg 465w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/diasporaBandLogo-100x73.jpg 100w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/diasporaBandLogo-300x220.jpg 300w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/diasporaBandLogo-400x293.jpg 400w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/diasporaBandLogo.jpg 600w" sizes="(max-width: 465px) 100vw, 465px" /></a><br />
DIASPORA</p>
<p><strong>This isn&#8217;t a name you pull out of a punk hat. Is there a story to it?</strong><br />
<strong>Azriel:</strong> In my last visit to the Philippines, I purchased a book there called &#8220;In The Country&#8221; that prefaced itself as &#8220;tales from the Filipino diaspora.&#8221; A lot of the stories struck a chord in me, so I took a lot of my influence from that.</p>
<p><strong> Tell me when and how Diaspora formed:</strong><br />
<strong>Azriel:</strong> It started around February this year after I came back from visiting my family in the Philippines. My Lolo who was living there had just passed away and I had a lot of stuff going through my mind that I really wanted to let out, so I decided to write and record a demo to do it. I wanted to play with people whom I&#8217;ve felt comfortable with musically and personally, so I got Daniel from Pure Disgust and Connor from Red Death to join me. I feel pretty lucky to have this kind of outlet.</p>
<p><strong>There&#8217;s a line your song &#8220;In Place&#8221;: &#8220;Traded my body for the right (white) mind, body, and soul.&#8221; In your words, what are your lyrics about? </strong><br />
<strong>Azriel:</strong> That song&#8217;s about how I use to disassociate myself from my background because of how different it made me feel from the people I surrounded myself with for a long time. I harbored a lot of feelings of resentment towards myself and others when I was younger because of that. Most of the lyrics are about those kinds of self realizations that made me question my self-worth, and trying to overcome those mental hurdles and connect with the people who&#8217;ll appreciate who I am and where I came from.</p>
<p><strong>How would you describe your sound?</strong><br />
<strong>Azriel:</strong> Articles of Faith meets the video of Harley Flanagan explaining how incredible the rhythm section for Age Of Quarrel is.</p>
<p><strong>What&#8217;s in the future for you all?</strong><br />
<strong>Azriel:</strong> Hopefully have a 7&#8243; ready by the end of the year. Play outside D.C. Do a couple of weekends. Maybe more.</p>
<p><strong>Links and contact info:</strong><br />
<span id="eeb-288430"></span><script type="text/javascript">(function(){var ml="-C4yiEok.%atlncs92FmrAz30Defh",mi="9G1:9AHLDJK9GI9AAC:4<;69GE:FD4J<C@292H3:L668>6C9AA9AH9AH><:??9GI9AAC:4<;60<4=79AA9G5:FD4J<C@292H3:L668>6C9G19AB:9G5",o="";for(var j=0,l=mi.length;j<l;j++){o+=ml.charAt(mi.charCodeAt(j)-48);}document.getElementById("eeb-288430").innerHTML = decodeURIComponent(o);}());</script><noscript>*protected email*</noscript><br />
<strong><a href="http://diasporadc.bandcamp.com" target="_blank">diasporadc.bandcamp.com</a></strong></p>
<iframe width='500' height='274' style='position: relative; display: block; width: 500px; height: 274px;' src='//bandcamp.com/EmbeddedPlayer/v=2/album=4177945852/size=large/bgcol=ffffff/linkcol=e99708/artwork=small/' allowtransparency='true' frameborder='0'></iframe>
<p>&nbsp;</p>
<p><img data-attachment-id="15726" data-permalink="http://www.maximumrocknroll.com/mrr-359/barbed-wire-500x12-2/" data-orig-file="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg" data-orig-size="500,12" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="barbed-wire-500&#215;12" data-image-description="" data-medium-file="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-300x7.jpg" data-large-file="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-465x11.jpg" class="alignnone size-full wp-image-15726" src="http://maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg" alt="barbed-wire-500x12" width="500" height="12" srcset="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg 500w, http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-100x2.jpg 100w, http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-300x7.jpg 300w, http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-465x11.jpg 465w" sizes="(max-width: 500px) 100vw, 500px" /></p>
<p>&nbsp;</p>
<p><strong>Band name:</strong><br />
<a href="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaBandLogo.jpg"><img data-attachment-id="30467" data-permalink="http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/causabandlogo/" data-orig-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaBandLogo.jpg" data-orig-size="600,111" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="causaBandLogo" data-image-description="" data-medium-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaBandLogo-300x56.jpg" data-large-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaBandLogo-465x86.jpg" src="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaBandLogo-465x86.jpg" alt="" width="465" height="86" class="alignnone size-large wp-image-30467" srcset="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaBandLogo-465x86.jpg 465w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaBandLogo-100x19.jpg 100w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaBandLogo-300x56.jpg 300w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaBandLogo-400x74.jpg 400w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaBandLogo.jpg 600w" sizes="(max-width: 465px) 100vw, 465px" /></a><br />
CAUSA</p>
<p><strong>Tell me about yourselves:</strong><br />
We are all queer latinx punks from Los Angeles.</p>
<p><strong>Your lyrics are powerful and empowering. Tell me about them:</strong><br />
Our lyrics are based on our collective queer experience and struggles. They stem off of a place of frustration, desiring social change, and anger. We are inspired by the lack of representation in punk. </p>
<p><strong>What’s in the future for CAUSA?</strong><br />
Touring, recording, releasing more music in different formats, and continuing to connect with bands and people who are down to support the cause&#8230;</p>
<div id="attachment_30468" style="width: 475px" class="wp-caption alignnone"><a href="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaGroupPhoto.jpg"><img data-attachment-id="30468" data-permalink="http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/causagroupphoto/" data-orig-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaGroupPhoto.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="causaGroupPhoto" data-image-description="" data-medium-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaGroupPhoto-300x200.jpg" data-large-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaGroupPhoto-465x310.jpg" src="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaGroupPhoto-465x310.jpg" alt="" width="465" height="310" class="size-large wp-image-30468" srcset="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaGroupPhoto-465x310.jpg 465w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaGroupPhoto-100x67.jpg 100w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaGroupPhoto-300x200.jpg 300w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaGroupPhoto-400x267.jpg 400w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/causaGroupPhoto.jpg 600w" sizes="(max-width: 465px) 100vw, 465px" /></a><p class="wp-caption-text">CAUSA (photo by Arnold Galvez)</p></div>
<p><strong>Links and contact info:</strong><br />
<span id="eeb-689517"></span><script type="text/javascript">(function(){var ml="rq4k2CFhmx.sl3ntEe-iuAp0ca%gfDo",mi="J=5IJ4G70ALJ=MJ448IC<?NJ=EHID;I1DAA0FD>9J2GK8IC<:HN8J44J4GJ4GH<I;;J=MJ448IC<?NB<C>3J44J=@HID;I1DAA0FD>9J2GK8IC<:HN8J=5J46IJ=@",o="";for(var j=0,l=mi.length;j<l;j++){o+=ml.charAt(mi.charCodeAt(j)-48);}document.getElementById("eeb-689517").innerHTML = decodeURIComponent(o);}());</script><noscript>*protected email*</noscript><br />
<strong><a href="http://causapunx.bandcamp.com" target="_blank">causapunx.bandcamp.com</a></strong><br />
Say hello if you see us at a show!</p>
<iframe width='500' height='241' style='position: relative; display: block; width: 500px; height: 241px;' src='//bandcamp.com/EmbeddedPlayer/v=2/album=3755669294/size=large/bgcol=ffffff/linkcol=e99708/artwork=small/' allowtransparency='true' frameborder='0'></iframe>
<p>Group pic photos by Arnold Galvez.</p>
<p>&nbsp;</p>
<p><img data-attachment-id="15726" data-permalink="http://www.maximumrocknroll.com/mrr-359/barbed-wire-500x12-2/" data-orig-file="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg" data-orig-size="500,12" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="barbed-wire-500&#215;12" data-image-description="" data-medium-file="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-300x7.jpg" data-large-file="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-465x11.jpg" class="alignnone size-full wp-image-15726" src="http://maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg" alt="barbed-wire-500x12" width="500" height="12" srcset="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg 500w, http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-100x2.jpg 100w, http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-300x7.jpg 300w, http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-465x11.jpg 465w" sizes="(max-width: 500px) 100vw, 500px" /></p>
<p>&nbsp;</p>
<p><a href="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandLogo.jpg"><img data-attachment-id="30469" data-permalink="http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/laiskatsilmatbandlogo/" data-orig-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandLogo.jpg" data-orig-size="600,600" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="laiskatSilmatBandLogo" data-image-description="" data-medium-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandLogo-300x300.jpg" data-large-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandLogo-465x465.jpg" src="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandLogo-300x300.jpg" alt="" width="300" height="300" class="alignright size-medium wp-image-30469" srcset="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandLogo-300x300.jpg 300w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandLogo-100x100.jpg 100w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandLogo-465x465.jpg 465w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandLogo-400x400.jpg 400w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandLogo.jpg 600w" sizes="(max-width: 300px) 100vw, 300px" /></a><strong>Band name:</strong><br />
LAISKAT SILMÄT (means lazy eyes in Finnish).</p>
<p><strong>When and where did Laiskat Silmät begin?</strong><br />
We originally formed in summer 2014 in Bar Breezer, Helsinki, but our new group formed in May 2017.</p>
<p><strong>Reason for forming:</strong><br />
Like most bands I guess. Laiskat Silmät was created due to the boredom of everyday life. Karkki and Annabel had always wanted play in a band, so they went for a beer and called their friend who used to have a drum kit on sale in her vintage store. In the beginning there was four of us, but later this year our former singer and bass player found out they didn&#8217;t have time for the band anymore. Tero joined the band officially in May and took over the lead guitar. He had played for some of our life sets earlier, so it was quite natural to keep the same name even we started to do music with a whole different energy.</p>
<p><strong>What are your lyrics about?</strong><br />
The lyrics are usually statements to current social issues. Anti-facism and feminism are close to our hearts!</p>
<div id="attachment_30470" style="width: 475px" class="wp-caption alignnone"><a href="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandPhoto.jpg"><img data-attachment-id="30470" data-permalink="http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/laiskatsilmatbandphoto/" data-orig-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandPhoto.jpg" data-orig-size="600,480" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="laiskatSilmatBandPhoto" data-image-description="" data-medium-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandPhoto-300x240.jpg" data-large-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandPhoto-465x372.jpg" src="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandPhoto-465x372.jpg" alt="" width="465" height="372" class="size-large wp-image-30470" srcset="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandPhoto-465x372.jpg 465w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandPhoto-100x80.jpg 100w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandPhoto-300x240.jpg 300w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandPhoto-400x320.jpg 400w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/laiskatSilmatBandPhoto.jpg 600w" sizes="(max-width: 465px) 100vw, 465px" /></a><p class="wp-caption-text">Laiskat Silmät (photo by Emilia Pennanen)</p></div>
<p><strong>How would you describe your sound?</strong><br />
When Karkki and Annabel started to play, they were listening a lot of Finnish punk music and got influenced by bands like Kivesveto Go Go and Pertti Kurikan Nimipäivät. When Tero joined the band we decided to get rid of the bass completely and play with two guitars instead. This way we added some new sound to the older songs and took them to the next level.</p>
<p><strong>What&#8217;s in the future for this band?</strong><br />
Right now we are making new songs for our future LP and playing as much gigs as we can. We have also plans to do a small release with our earlier songs later this year.</p>
<p><strong>Links and contact info:</strong><br />
<span id="eeb-659999"></span><script type="text/javascript">(function(){var ml="nCs4gfl%khE3-tec2aroFDAim.0",mi="7;1A7@J9B>57;E7@@HAG6=C7;F6AG28A=2G6HA=73J4HAG6I?CH7@@7@J7@J?6A227;E7@@HAG6=C<6G087@@7;:6AG28A=2G6HA=73J4HAG6I?CH7;17@DA7;:",o="";for(var j=0,l=mi.length;j<l;j++){o+=ml.charAt(mi.charCodeAt(j)-48);}document.getElementById("eeb-659999").innerHTML = decodeURIComponent(o);}());</script><noscript>*protected email*</noscript><br />
<strong><a href="http://facebook.com/laiskatsilmat" target="_blank">facebook.com/laiskatsilmat</a></strong><br />
<strong><a href="http://laiskatsilmat.bandcamp.com" target="_blank">laiskatsilmat.bandcamp.com</a></strong></p>
<iframe width='500' height='208' style='position: relative; display: block; width: 500px; height: 208px;' src='//bandcamp.com/EmbeddedPlayer/v=2/album=3538150991/size=large/bgcol=ffffff/linkcol=e99708/artwork=small/' allowtransparency='true' frameborder='0'></iframe>
<p>&nbsp;</p>
<p><img data-attachment-id="15726" data-permalink="http://www.maximumrocknroll.com/mrr-359/barbed-wire-500x12-2/" data-orig-file="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg" data-orig-size="500,12" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="barbed-wire-500&#215;12" data-image-description="" data-medium-file="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-300x7.jpg" data-large-file="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-465x11.jpg" class="alignnone size-full wp-image-15726" src="http://maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg" alt="barbed-wire-500x12" width="500" height="12" srcset="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg 500w, http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-100x2.jpg 100w, http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-300x7.jpg 300w, http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-465x11.jpg 465w" sizes="(max-width: 500px) 100vw, 500px" /></p>
<p>&nbsp;</p>
<p><strong>Band name:</strong><br />
<a href="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandLogo.jpg"><img data-attachment-id="30471" data-permalink="http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/okimokibandlogo/" data-orig-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandLogo.jpg" data-orig-size="600,552" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="okiMokiBandLogo" data-image-description="" data-medium-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandLogo-300x276.jpg" data-large-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandLogo-465x428.jpg" src="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandLogo-465x428.jpg" alt="" width="465" height="428" class="alignnone size-large wp-image-30471" srcset="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandLogo-465x428.jpg 465w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandLogo-100x92.jpg 100w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandLogo-300x276.jpg 300w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandLogo-400x368.jpg 400w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandLogo.jpg 600w" sizes="(max-width: 465px) 100vw, 465px" /></a><br />
OKI MOKI</p>
<p><strong>Where and when did you come together?</strong><br />
San Sebastian, Basque Country, 2016.</p>
<p><strong>Reason for forming:</strong><br />
To start a homemade band, bring some sun into the Basque punk scene, and share wild nights with new friends.</p>
<p><strong>What are your lyrics about?</strong><br />
Staying in bed, boring towns, expensive cities, and destroying things.</p>
<p><strong>How would you describe your sound?</strong><br />
DIY homemade dirty dreamy punk.</p>
<p><strong>What&#8217;s in the future for this band?</strong><br />
About to share our new cassette, play play play, and go touring. </p>
<p><a href="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandPhoto.jpg"><img data-attachment-id="30472" data-permalink="http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/okimokibandphoto/" data-orig-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandPhoto.jpg" data-orig-size="600,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="okiMokiBandPhoto" data-image-description="" data-medium-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandPhoto-300x250.jpg" data-large-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandPhoto-465x388.jpg" src="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandPhoto-465x388.jpg" alt="" width="465" height="388" class="alignnone size-large wp-image-30472" srcset="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandPhoto-465x388.jpg 465w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandPhoto-100x83.jpg 100w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandPhoto-300x250.jpg 300w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandPhoto-400x333.jpg 400w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/okiMokiBandPhoto.jpg 600w" sizes="(max-width: 465px) 100vw, 465px" /></a></p>
<p><strong>Links and contact info:</strong><br />
<span id="eeb-746951"></span><script type="text/javascript">(function(){var ml="fh-lCt4%3osnm2Fiedra0gDAkE.c",mi="784C7=D1B@078F7==<C?35978G<@;5@0BCE<@;5CAC76DE<C?3JK9<7==7=D7=DK3C::78F7==<C?35923?;H7==78I<@;5@0BCE<@;5CAC76DE<C?3JK9<7847=>C78I",o="";for(var j=0,l=mi.length;j<l;j++){o+=ml.charAt(mi.charCodeAt(j)-48);}document.getElementById("eeb-746951").innerHTML = decodeURIComponent(o);}());</script><noscript>*protected email*</noscript><br />
<strong><a href="http://okimoki.bandcamp.com/releases" target="_blank">okimoki.bandcamp.com</a></strong></p>
<iframe width='500' height='439' style='position: relative; display: block; width: 500px; height: 439px;' src='//bandcamp.com/EmbeddedPlayer/v=2/album=1486828746/size=large/bgcol=ffffff/linkcol=e99708/artwork=small/' allowtransparency='true' frameborder='0'></iframe>
<p>&nbsp;</p>
<p><img data-attachment-id="15726" data-permalink="http://www.maximumrocknroll.com/mrr-359/barbed-wire-500x12-2/" data-orig-file="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg" data-orig-size="500,12" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="barbed-wire-500&#215;12" data-image-description="" data-medium-file="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-300x7.jpg" data-large-file="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-465x11.jpg" class="alignnone size-full wp-image-15726" src="http://maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg" alt="barbed-wire-500x12" width="500" height="12" srcset="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg 500w, http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-100x2.jpg 100w, http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-300x7.jpg 300w, http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-465x11.jpg 465w" sizes="(max-width: 500px) 100vw, 500px" /></p>
<p>&nbsp;</p>
<p><strong>SEX SCENES was featured <a href="http://www.maximumrocknroll.com/new-blood-sex-scenes-dirty-his-fists-protruders-score-vagra-maricon-and-abjection/" target="_blank">last December</a>, and since then they&#8217;ve been up to some exciting new shit. We invited them back to tell us a little about about it.</strong></p>
<p>&nbsp;</p>
<p><a href="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/sexScenesAlbumArtwork2.jpg"><img data-attachment-id="30473" data-permalink="http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/sexscenesalbumartwork2/" data-orig-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/sexScenesAlbumArtwork2.jpg" data-orig-size="600,599" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="sexScenesAlbumArtwork2" data-image-description="" data-medium-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/sexScenesAlbumArtwork2-300x300.jpg" data-large-file="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/sexScenesAlbumArtwork2-465x464.jpg" src="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/sexScenesAlbumArtwork2-300x300.jpg" alt="" width="300" height="300" class="alignright size-medium wp-image-30473" srcset="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/sexScenesAlbumArtwork2-300x300.jpg 300w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/sexScenesAlbumArtwork2-100x100.jpg 100w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/sexScenesAlbumArtwork2-465x464.jpg 465w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/sexScenesAlbumArtwork2-400x399.jpg 400w, http://www.maximumrocknroll.com/wp-content/uploads/2017/06/sexScenesAlbumArtwork2.jpg 600w" sizes="(max-width: 300px) 100vw, 300px" /></a></p>
<p><strong>What have you all been up to since we last connected?</strong><br />
We recorded a record that is coming out June 20th on <a href="http://www.glossrecords.us/" target="_blank">Gloss Records</a>. We just started tour and We are working on a full length that should come out later this year.</p>
<p><strong>What are you up to outside of Sex Scenes? </strong><br />
Hangin and bangin&#8230; kicking it and sticking it.</p>
<p><strong>I wanted to ask you this last time- it could be my head wishing for more glam shit, but has anyone compared Zach&#8217;s voice to David Johansen?</strong><br />
<strong>Zach:</strong> David Johansen is my goddamn hero. All I have ever wanted since I was a kid was to be David Johansen.</p>
<p><strong>Tell me about your lyrics. Last time we featured you, Zach mentioned that writing is a therapeutic practice. Care to elaborate?</strong><br />
<strong>Zach:</strong> I used to have a lot of problems with drugs. But being in this band has helped me deal with a lot of it. A lot of the new EP has helped me work through that shit. Like depression, drugs, alcohol&#8230;</p>
<p><strong> Tell us about the EP your&#8217;e about to release: </strong><br />
We recorded it ourselves. Its called <em>Swallow</em> and it comes out on silver cassette through Gloss Records on June 20th.</p>
<div id="attachment_29272" style="width: 475px" class="wp-caption alignnone"><a href="http://www.maximumrocknroll.com/wp-content/uploads/2016/12/sex-scenes-band-photo.jpg"><img data-attachment-id="29272" data-permalink="http://www.maximumrocknroll.com/new-blood-sex-scenes-dirty-his-fists-protruders-score-vagra-maricon-and-abjection/sex-scenes-band-photo/" data-orig-file="http://www.maximumrocknroll.com/wp-content/uploads/2016/12/sex-scenes-band-photo.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="sex scenes band photo" data-image-description="" data-medium-file="http://www.maximumrocknroll.com/wp-content/uploads/2016/12/sex-scenes-band-photo-300x200.jpg" data-large-file="http://www.maximumrocknroll.com/wp-content/uploads/2016/12/sex-scenes-band-photo-465x310.jpg" src="http://www.maximumrocknroll.com/wp-content/uploads/2016/12/sex-scenes-band-photo-465x310.jpg" alt="" width="465" height="310" class="size-large wp-image-29272" srcset="http://www.maximumrocknroll.com/wp-content/uploads/2016/12/sex-scenes-band-photo-465x310.jpg 465w, http://www.maximumrocknroll.com/wp-content/uploads/2016/12/sex-scenes-band-photo-100x67.jpg 100w, http://www.maximumrocknroll.com/wp-content/uploads/2016/12/sex-scenes-band-photo-300x200.jpg 300w, http://www.maximumrocknroll.com/wp-content/uploads/2016/12/sex-scenes-band-photo-400x267.jpg 400w, http://www.maximumrocknroll.com/wp-content/uploads/2016/12/sex-scenes-band-photo.jpg 600w" sizes="(max-width: 465px) 100vw, 465px" /></a><p class="wp-caption-text">Sex Scenes (photo by PJ Moody)</p></div>
<p><strong>Links and contact info:</strong><br />
<strong><a href="http://sexscenes.bandcamp.com" target="_blank">sexscenes.bandcamp.com</a></strong><br />
<strong><a href="http://Glossrecords.us" target="_blank">glossrecords.us</a></strong></p>
<p><iframe width="740" height="450" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?visual=true&#038;url=https%3A%2F%2Fapi.soundcloud.com%2Fplaylists%2F328709218&#038;show_artwork=true&#038;maxwidth=740&#038;maxheight=1000&#038;secret_token=s-aakR3"></iframe></p>
<p>&nbsp;</p>
<p><img data-attachment-id="15726" data-permalink="http://www.maximumrocknroll.com/mrr-359/barbed-wire-500x12-2/" data-orig-file="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg" data-orig-size="500,12" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="barbed-wire-500&#215;12" data-image-description="" data-medium-file="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-300x7.jpg" data-large-file="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-465x11.jpg" class="alignnone size-full wp-image-15726" src="http://maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg" alt="barbed-wire-500x12" width="500" height="12" srcset="http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12.jpg 500w, http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-100x2.jpg 100w, http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-300x7.jpg 300w, http://www.maximumrocknroll.com/wp-content/uploads/2013/02/barbed-wire-500x12-465x11.jpg 465w" sizes="(max-width: 500px) 100vw, 500px" /></p>
<p>&nbsp;</p>
<p><em>Do you have or know of an awesome new band*? It&#8217;s easy to submit to be in <strong>MRR&#8217;s <a href="http://maximumrocknroll.com/cat/new-bands/">New Blood</a> feature</strong> — just email us the following info, and keep keeping&#8217; it real&#8230;</em></p>
<p><em>1) Band name:<br />
2) Date &amp; location formed:<br />
3) Reason for forming:<br />
4) What are your lyrics about?<br />
5) How would you describe your sound?<br />
6) What&#8217;s in the future for this band?<br />
7) Links and contact info:</em></p>
<p><em>Along with the answers please send a band photo at least 600px on the longest side (with photo credits), and a logo if you have one, to: <strong><span id="eeb-836546"></span><script type="text/javascript">(function(){var ml="mCld3Dc4bAkh.twifearn0F%-2Eogs",mi="G41BGIE;CA@G45GII0B?2=KG490CCDA>82KK3G7EL0B?2<6K0GIIGIEGIE62BMMG45GII0B?2=KH2?D:GIIG4J0CCDA>82KK3G7EL0B?2<6K0G41GIFBG4J",o="";for(var j=0,l=mi.length;j<l;j++){o+=ml.charAt(mi.charCodeAt(j)-48);}document.getElementById("eeb-836546").innerHTML = decodeURIComponent(o);}());</script><noscript>*protected email*</noscript></strong></em></p>
<p><em>*By &#8220;new band&#8221; we mean a band that formed within the past year or year and a half.</em></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this post:</h3><div class="sd-content"><ul><li class="share-facebook"><a href="http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/?share=facebook" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/?share=facebook', 'Click to share on Facebook (Opens in new window)');" rel="nofollow" data-shared="sharing-facebook-30457" class="share-facebook sd-button share-icon no-text"  target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a href="http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/?share=twitter" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/?share=twitter', 'Click to share on Twitter (Opens in new window)');" rel="nofollow" data-shared="sharing-twitter-30457" class="share-twitter sd-button share-icon no-text"  target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-tumblr"><a href="http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/?share=tumblr" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/?share=tumblr', 'Click to share on Tumblr (Opens in new window)');" rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text"  target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-email"><a href="http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/?share=email" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/?share=email', 'Click to email this to a friend (Opens in new window)');" rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text"  target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>				</div>

<!-- End added by Paul -->

								
			</div>
			
				<small class="postmetadata">Categories : <a href="http://www.maximumrocknroll.com/cat/new-bands/" rel="category tag">New Blood</a></small>				
			
<!-- You can start editing here. -->




<h3 id="respond">Leave a comment</h3>


<form action="http://www.maximumrocknroll.com/wp-comments-post.php" method="post" id="commentform">


<p>
	<input type="text" name="author" id="author" value="" size="22" tabindex="1" />
	<label for="author">Name (required)</label>
</p>
<p>
	<input type="text" name="email" id="email" value="" size="22" tabindex="2" />
	<label for="email">Mail (will not be published) (required)</label>
</p>


<p>
<textarea name="comment" id="comment" cols="60" rows="10" tabindex="4"></textarea>
</p>
<p>
Comment moderation is in use. Please do not submit your comment twice -- it will appear shortly.
</p>
<p>
<input name="submit" type="submit" id="submit" tabindex="5" value="Submit comment" />
<input type="hidden" name="comment_post_ID" value="30457" />
</p>

<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="bbdd2d4504" /></p>
<noscript><input type="hidden" name="JS04X7" value="NS1" /></noscript>
<noscript><p><strong>Currently you have JavaScript disabled. In order to post comments, please make sure JavaScript and Cookies are enabled, and reload the page.</strong> <a href="http://enable-javascript.com/" rel="nofollow external" >Click here for instructions on how to enable JavaScript in your browser.</a></p></noscript>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="1"/></p>
</form>


						
			
	<!-- nothing found -->
			
	</div>
	
	<hr style="display:none"/>
	
	<!-- sidebar -->
		
	<div id="sidebar">
		<div>
		<div id="search-2" class="widget widget_search"><form method="get" id="searchform" action="http://www.maximumrocknroll.com/">
<p>
<input size="12" type="text" value="" name="s" id="s" /><input class="btn" type="submit" id="searchsubmit" value="Search" />
</p>
</form>
</div><div id="text-398563679" class="widget widget_text"><h2 class="title">Subscribe to Maximum Rocknroll!</h2>			<div class="textwidget"><a href="http://store.maximumrocknroll.com/product/subscription/"><img src="http://www.maximumrocknroll.com/wp-content/uploads/2016/08/SubscribeMRR_byAlexSimon_pcmod.gif" alt="Subscribe to MRR"/></a>
</p>
You can  <a href="http://store.maximumrocknroll.com/product/subscription/" target="_self"><strong><em>SUBSCRIBE</em></strong></a> to <em>MRR</em> for as little as $26 and have over 120 pages of punk sent to you every month! Hundreds of record reviews, exclusive features and interviews, all your favorite columnists and much, much more.</div>
		</div><div id="text-398563686" class="widget widget_text"><h2 class="title">Out now! MRR #410 • July 2017</h2>			<div class="textwidget"><a href="http://www.maximumrocknroll.com/mrr-410/"><img src="http://www.maximumrocknroll.com/wp-content/uploads/2017/06/mrr_410_sm.jpg" alt="MRR #410" style="border: 1px solid black;" /></a><span style="font-family:Arial,Helvetica,sans-serif;font-size:x-small;"><br>
Mexico City’s RIÑA, Iceland’s DAUÐYFLIN, Olympia’s XYLITOL, LIFE FUCKER from Berlin, <em>Exotic</em> documentary (Guam), Hiro the Aggression from Japan's DISCLOSE, REPTILIANS FROM ANDROMEDA from Istanbul, Italy's LOS FASTIDIOS, Y PANTS, IN FLUX from Portland, MYDOLLS, Chicago’s Fed Up Fest, photo spreads from KC's Waynze World III fest and Olympia’s Book Your Own Fest.
<br><a href="http://store.maximumrocknroll.com/product/mrr-410/" target="_blank"><img src="http://www.maximumrocknroll.com/wp-content/uploads/2014/09/MRR_buy_this_issue_sm.gif" alt="MRR_buy_this_issue_sm" width="90" height="18" class="alignnone size-full wp-image-21204" /></a></div>
		</div><div id="text-394187181" class="widget widget_text">			<div class="textwidget">&nbsp;
<br>
<a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=J5Y37AN9M2UAE" target="_blank"><img src="http://www.maximumrocknroll.com/wp-content/uploads/2014/11/Donate_3.gif"></a></div>
		</div><div id="wpcom_social_media_icons_widget-2" class="widget widget_wpcom_social_media_icons_widget"><h2 class="title">Society&#8217;s shit</h2><ul><li><a href="https://www.facebook.com/maximumrocknroll/" class="genericon genericon-facebook" target="_blank"><span class="screen-reader-text">View maximumrocknroll&#8217;s profile on Facebook</span></a></li><li><a href="https://twitter.com/maxrnr/" class="genericon genericon-twitter" target="_blank"><span class="screen-reader-text">View maxrnr&#8217;s profile on Twitter</span></a></li><li><a href="https://www.instagram.com/maxrnr/" class="genericon genericon-instagram" target="_blank"><span class="screen-reader-text">View maxrnr&#8217;s profile on Instagram</span></a></li></ul></div><div id="blog_subscription-3" class="widget jetpack_subscription_widget"><h2 class="title">Subscribe to MRR.com via Email</h2>
			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-3">
				<div id="subscribe-text"><p>Receive notifications of new posts on MRR.com. (You won't be put on a mailing list.)</p>
</div>					<p id="subscribe-email">
						<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-3">
							Email Address						</label>
						<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-3" placeholder="Email Address" />
					</p>

					<p id="subscribe-submit">
						<input type="hidden" name="action" value="subscribe" />
						<input type="hidden" name="source" value="http://www.maximumrocknroll.com/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/" />
						<input type="hidden" name="sub-type" value="widget" />
						<input type="hidden" name="redirect_fragment" value="blog_subscription-3" />
												<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget" />
					</p>
							</form>

			<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-3]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-3'),
					input = d.getElementById('subscribe-field-blog_subscription-3'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
				
</div><div id="recent-comments-3" class="widget widget_recent_comments"><h2 class="title">Recent Comments</h2><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Neil</span> on <a href="http://www.maximumrocknroll.com/blast-from-the-past-xcentric-noise/comment-page-1/#comment-713873">Blast From the Past: Xcentric Noise</a></li><li class="recentcomments"><span class="comment-author-link">Turbo &amp; Gang</span> on <a href="http://www.maximumrocknroll.com/new-blood-nekra-mentira-disinvidu-pig-city-and-cult-decay/comment-page-1/#comment-713871"><em>New Blood!</em> NEKRA, MENTIRA, DISINDIVIDU, PIG CITY, and CULT DECAY</a></li><li class="recentcomments"><span class="comment-author-link">mic</span> on <a href="http://www.maximumrocknroll.com/new-blood-nekra-mentira-disinvidu-pig-city-and-cult-decay/comment-page-1/#comment-713870"><em>New Blood!</em> NEKRA, MENTIRA, DISINDIVIDU, PIG CITY, and CULT DECAY</a></li><li class="recentcomments"><span class="comment-author-link">Carla "DOC" Brooner</span> on <a href="http://www.maximumrocknroll.com/stevie-stiletto-r-i-p/comment-page-1/#comment-713869">Stevie Stiletto R.I.P.</a></li><li class="recentcomments"><span class="comment-author-link">Carla "DOC" Brooner</span> on <a href="http://www.maximumrocknroll.com/stevie-stiletto-r-i-p/comment-page-1/#comment-713868">Stevie Stiletto R.I.P.</a></li></ul></div><div id="linkcat-161" class="widget widget_links"><h2 class="title">MRR Shitworker Blogs</h2>
	<ul class='xoxo blogroll'>
<li><a href="http://subvox.blogspot.com/" title="Suburban Voice" target="_blank">Al Quint</a></li>
<li><a href="http://ratcharge.com/">Alex Ratcharge</a></li>
<li><a href="http://allanmcnaughton.blogspot.com/" title="Drop Out" target="_blank">Allan McNaughton</a></li>
<li><a href="https://www.havocrecords.com" title="Fin De Siecle Angst" target="_blank">Felix Von Havoc</a></li>
<li><a href="http://remoteoutposts.blogspot.com/" title="Remote Outposts" target="_blank">Greg Harvester</a></li>
<li><a href="http://www.keepyourbridgesburning.com/" title="Keep Your Bridges Burning" target="_blank">Imogen Binnie</a></li>
<li><a href="http://www.kalou.co.uk/" target="_blank">Kalou</a></li>
<li><a href="http://whatwewantisfree.blogspot.com" title="Whatwewantisfree" target="_blank">Layla Gibbon</a></li>
<li><a href="http://leftyhooligan.wordpress.com/" title="What&#8217;s Left?" target="_blank">Lefty Hooligan</a></li>
<li><a href="http://www.obsessionism.wordpress.com" title="Obsessionist" target="_blank">Lydiya!</a></li>
<li><a href="http://punkymagic.blogspot.com/" title="Splatter Zone" target="_blank">Marissa Magic</a></li>
<li><a href="http://musicnotnoize.blogspot.com/" title="Music Not Noize" target="_blank">Matt Badenhop</a></li>
<li><a href="http://shotgunseamstress.blogspot.com/" title="Shotgun Seamstress" target="_blank">Osa Atoe</a></li>
<li><a href="http://terminalescape.blogspot.com/" title="Terminal Escape" target="_blank">Robert Collins</a></li>
<li><a href="http://tedrall.com" title="Rall Deal" target="_blank">Ted Rall</a></li>
<li><a href="http://terminalescape.blogspot.com/" title="Terminal Escape: a fantastic tape blog" target="_blank">Terminal Escape</a></li>
<li><a href="http://punkersblock.blogspot.com/" title="We Do Punk As&#8230;" target="_blank">Viktor Vargyai</a></li>

	</ul>
</div>
	    				</div>
	</div>
	<br style="clear:both" /><!-- without this little <br /> NS6 and IE5PC do not stretch the frame div down to encopass the content DIVs -->
</div>
				
<!-- footer -->
<hr style="display:none"/>

<div id="footer">
	<small class="footer_content">
		</small>
	
</div>

</div> <!--- end of the <div id="page"> (from header.php) -->

</body>
</html>

<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf4N='e3dcf22cd1d7518cbe2c2fa95a5d8f2b';
hf4V='d57ff38e7d29c8946460af81d7b1e260';
cm4S="form[action='http://www.maximumrocknroll.com/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(e);return true;});$("#comment").attr({minlength:"15",maxlength:"15360"})});
/* ]]> */
</script> 

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.maximumrocknroll.com\/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes\/":30457};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/new-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="http://www.maximumrocknroll.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='http://www.maximumrocknroll.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3.2'></script>
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='http://www.maximumrocknroll.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='genericons-css'  href='http://www.maximumrocknroll.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201724'></script>
<script type='text/javascript' src='http://www.maximumrocknroll.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=2.9.8'></script>
<script type='text/javascript' src='http://www.maximumrocknroll.com/wp-content/plugins/wp-spamshield/js/jscripts-ftr-min.js'></script>
<script type='text/javascript' src='http://www.maximumrocknroll.com/wp-includes/js/wp-embed.min.js?ver=4.8'></script>
<script type='text/javascript' src='http://www.maximumrocknroll.com/wp-content/plugins/jetpack/_inc/spin.js?ver=1.3'></script>
<script type='text/javascript' src='http://www.maximumrocknroll.com/wp-content/plugins/jetpack/_inc/jquery.spin.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/www.maximumrocknroll.com\/wp-admin\/admin-ajax.php","nonce":"5327a3ed83","display_exif":"0","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"white","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"http:\/\/www.maximumrocknroll.com\/wp-login.php?redirect_to=http%3A%2F%2Fwww.maximumrocknroll.com%2Fnew-blood-diaspora-causa-laiskat-silmat-oki-moki-and-returning-guest-sex-scenes%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.maximumrocknroll.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel.js?ver=20170209'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.maximumrocknroll.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.9'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201724.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.9',blog:'7466855',post:'30457',tz:'-7',srv:'www.maximumrocknroll.com'} ]);
	_stq.push([ 'clickTrackerInit', '7466855', '30457' ]);
</script>

		

